import Foundation
let pattern = #"^((\d{4}).(\d{2}).(\d{1}).(\d{1,3}).(\d{1,3}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2018.30.3.0.4
SS.InSite-2018.30.3.0.4
2018.30.3.0.4
2018.30.3.0.4
2018.30.3.0.4TEst
20181.30.3.0.4
2018.301.3.0.4
2018.30.3.0.4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)