use strict;
my $str = '//good
1c.1c.0
v1c.1.asdf
errhand.LSD.asdf+dfsg
1.c1.asdf
c1.1.asdf
c1c.1.asdf
1.c1cc.asadf~dsf
//bad
1.1
1.1.1
1.00.00
v1c.1.
1.v1c.
1.01.01~sdgf
1.v1c.asdf-sadf+asdf
~1c.1c.0
1c.1~c.0';
my $regex = qr/^.*[a-zA-Z]+.*\..*[a-zA-Z]+.*\..*(~|\-|\+)*[a-zA-Z0-9]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}