import Foundation
let pattern = #"(SYS_FBA_)([A-Z_])+?([A-Z_1-9])*_([0-9]{5,6})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SYS_FBA_TCRV_IDX1_36953
SYS_FBA_TCRV_36953
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1HIST_\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)