$re = '/^(?:[^B\s]*(?:B{1,3}[^B\s]+)+B{0,3}|[^B\s]*B{1,3})$/m';
$str = 'sdBBdfsBBB
BfsBBBdsfBBB
aBBBaBBAaaabBBB
BBtestBBtestBBBtestBtestBBBtestBBBB
BB
test
aaBBB
B
BB
BBB
BBBB
aBBB
It shouldn\'t match:
fsBBBBsfBB
BBBBBfsBBBsd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);