#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)role:(?:\(\K[^()]+(?=\))|'\K[^']+(?='))"
Local $sString = ""languages:(ruby AND python) role:(software engineer or data scientist)"" & @CRLF & _
""role:(software engineer or data scientist) languages:(ruby AND python)"" & @CRLF & _
""languages:'python' role:'software engineer'"" & @CRLF & _
""languages:(ruby AND python)role:(software engineer or data scientist)"" & @CRLF & _
""languages:'python'role:'software engineer'"" & @CRLF & _
""languages:'python'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")