using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"role:(?:\(\K[^()]+(?=\))|'\K[^']+(?='))";
string input = @"""languages:(ruby AND python) role:(software engineer or data scientist)""
""role:(software engineer or data scientist) languages:(ruby AND python)""
""languages:'python' role:'software engineer'""
""languages:(ruby AND python)role:(software engineer or data scientist)""
""languages:'python'role:'software engineer'""
""languages:'python'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}