const regex = /role:(?:\(\K[^()]+(?=\))|'\K[^']+(?='))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('role:(?:\\(\\K[^()]+(?=\\))|\'\\K[^\']+(?=\'))', 'gm')
const str = `"languages:(ruby AND python) role:(software engineer or data scientist)"
"role:(software engineer or data scientist) languages:(ruby AND python)"
"languages:'python' role:'software engineer'"
"languages:(ruby AND python)role:(software engineer or data scientist)"
"languages:'python'role:'software engineer'"
"languages:'python'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}