$re = '/role:(?:\(\K[^()]+(?=\))|\'\K[^\']+(?=\'))/m';
$str = '"languages:(ruby AND python) role:(software engineer or data scientist)"
"role:(software engineer or data scientist) languages:(ruby AND python)"
"languages:\'python\' role:\'software engineer\'"
"languages:(ruby AND python)role:(software engineer or data scientist)"
"languages:\'python\'role:\'software engineer\'"
"languages:\'python\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);