re = /role:(?:\(\K[^()]+(?=\))|'\K[^']+(?='))/m
str = '"languages:(ruby AND python) role:(software engineer or data scientist)"
"role:(software engineer or data scientist) languages:(ruby AND python)"
"languages:\'python\' role:\'software engineer\'"
"languages:(ruby AND python)role:(software engineer or data scientist)"
"languages:\'python\'role:\'software engineer\'"
"languages:\'python\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end