const regex = /(?<=^ *) /g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^ *) ', 'g')
const str = ` something is here`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);