// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d\D?){10}\d$").unwrap();
let string = "1 1 1 1 1 1 1 1 1 1 1
11111111111
1-1111111111
1.1.1.1.1.1.1.1.1.1.1
1 1 1 1 1 1 1 1 1 1 1
1--1111111111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}