package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[Uu]rl(?::|\b)\s?\b(.+?)(?:\s|$)`)
var str = `url: https://www.anysite/anything
url: https://www.anysite/anything another word
url: https://www.anysite/anything`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}