$re = '/[Uu]rl(?::|\b)\s?\b(.+?)(?:\s|$)/m';
$str = 'url: https://www.anysite/anything
url: https://www.anysite/anything another word
url: https://www.anysite/anything';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);