re = /[Uu]rl(?::|\b)\s?\b(.+?)(?:\s|$)/m
str = 'url: https://www.anysite/anything
url: https://www.anysite/anything another word
url: https://www.anysite/anything'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end