import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^?]+.*?&?q=([^$|&]+)";
final String string = "/myweb/search?s=islamic_sources&q=test\n"
+ "/myweb/search?q=test\n"
+ "/myweb/search?q=test&g=sth";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}