use strict;
my $str = '/myweb/search?s=islamic_sources&q=test
/myweb/search?q=test
/myweb/search?q=test&g=sth';
my $regex = qr/^[^?]+.*?&?q=([^$|&]+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";