re = /^[^?]+.*?&?q=([^$|&]+)/
str = '/myweb/search?s=islamic_sources&q=test
/myweb/search?q=test
/myweb/search?q=test&g=sth'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result