// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[^?]+.*?&?q=([^$|&]+)").unwrap();
let string = "/myweb/search?s=islamic_sources&q=test
/myweb/search?q=test
/myweb/search?q=test&g=sth";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}