using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-r(?:eason)?\s*""(.+?)(?:""\s*-|[^""]*$)";
string input = @"1 anything -reason ""some reason"" -anyArg ""anything""
2 anything -reason ""Hello World, you're the ""best"" -anyArg ""anything""
3 anything -r ""anything ""here"" is wrong"" anything";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}