package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-r(?:eason)?\s*"(.+?)(?:"\s*-|[^"]*$)`)
var str = `1 anything -reason "some reason" -anyArg "anything"
2 anything -reason "Hello World, you're the "best"" -anyArg "anything"
3 anything -r "anything "here" is wrong" anything`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}