# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!(?:\d{11})?[^\S\n]*$).*(?:\n(?!\d{11}[^\S\n]*$).*)*\n\d{11}[^\S\n]*$"
test_str = ("Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et doloreere34545 magna aliqua. \n\n"
"1\\. Ut enim ad minim 5453 veniam\n\n"
"2\\. quis nostrud exercitation ullamco \n"
"14567883390\n"
"laboris nisi ut aliquip ex ea commodo consequat.\n"
"12\\. Duis aute irure dolor in reprehenderit in voluptate \n"
"velit esse cillum dolore\n\n"
"23432434234 \n"
"eu fugiat nulla pariatur. Excepteur sint \n"
"occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.\n\n\n\n"
"23432434234 \n\n\n"
" \n\n\n\n"
"23432434234 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.