import Foundation
let pattern = #"^(?!(?:\d{11})?[^\S\n]*$).*(?:\n(?!\d{11}[^\S\n]*$).*)*\n\d{11}[^\S\n]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et doloreere34545 magna aliqua.
1\. Ut enim ad minim 5453 veniam
2\. quis nostrud exercitation ullamco
14567883390
laboris nisi ut aliquip ex ea commodo consequat.
12\. Duis aute irure dolor in reprehenderit in voluptate
velit esse cillum dolore
23432434234
eu fugiat nulla pariatur. Excepteur sint
occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
23432434234
23432434234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)