re = /(?:(\.[0-9]*[1-9])|\.)0+$/m
str = '0.0002300
10.0020300
100.00
1000
0.0
0 '
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result