$re = '/\b\d+(\.\d+)*\b/m';
$str = '1.1 2 2.1 3.12324132.42.42 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);