import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^id=abc(?:(?!value=).)*value=1";
final String string = "id=abc somethingelse value=1 value=2 value=3 value=1\n"
+ "String not to be matched:\n\n"
+ "id=abc somethingelse value=2 value=2 value=3 value=1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}