$re = '/(?(?=\s[1|0]\s)\s[0|1]\s|(\d+[,|.]\d+|\d+))/';
$str = ' 1778.89 0 45 987,45 1 5 6 1 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);