# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(?:[\da-f]{0,4}:){2,7}(?:(?<ipv4>(?:(?:25[0-5]|2[0-4]\d|1?\d\d?)\.){3}(?:25[0-5]|2[0-4]\d|1?\d\d?))|[\da-f]{0,4}|:)"
test_str = ("2001:0DB8:0000:CD30:0000:0000:0000:0000\n"
"2001:0DB8::CD30:0:0:0:0\n"
"2001:0DB8:0:CD30::\n"
"FF02:0:0:0:0:1:FF00:0000\n"
"FF02:0:0:0:0:1:FFFF:FFFF\n"
"2001:db8::1234:5678\n"
"FF02:0:0:0:0:0:0:2\n"
"fdf8:f53b:82e4::53\n"
"fe80::200:5aee:feaa:20a2\n"
"2001:0000:4136:e378:\n"
"8000:63bf:3fff:fdd2\n"
"2001:db8::\n"
"::1234:5678\n"
"2000::\n"
"2001:db8:a0b:12f0::1\n"
"2001:4:112:cd:65a:753:0:a1\n"
"2001:0002:6c::430\n"
"2001:5::\n"
"fe08::7:8\n"
"2001:10:240:ab::a\n"
"2002:cb0a:3cdd:1::1\n"
"2001:db8:8:4::2\n"
"FF01:0:0:0:0:0:0:2\n"
"::FFFF:0:0\n"
"2001:0000::\n"
"59fb:0:0:0:0:1005:cc57:6571 expansion of 59FB::1005:CC57:6571\n\n"
"# IPv4-Mapped and IPv4-Embedded\n"
"::ffff:192.0.2.47\n"
"::ffff:0.0.0.0\n"
"::ffff:255.255.255.255\n"
"::ffff:10.0.0.3\n"
"::192.168.0.1\n"
"::255.255.255.255\n"
"2001:db8:122:344::192.0.2.33\n"
"0:0:0:0:0:0:13.1.68.3\n"
"0:0:0:0:0:FFFF:129.144.52.3\n"
"::13.1.68.3\n"
"::FFFF:129.144.52.38\n\n"
"1:2:3:4:5:6:7:8\n"
"1::3:4:5:6:7:8\n"
"1::4:5:6:7:8\n"
"1:2:3::5:6:7:8\n"
"1::7:8\n"
"1:2:3:4:5::7:8\n"
"1:2:3:4:5::8\n\n\n"
"# Cases based on RIEP: https://www.ripe.net/participate/member-support/lir-basics/ipv6_reference_card.pdf\n"
":0: All zeroes in a single block can be represented\n"
"::1 Loopback - This address is used when a host talks to itself over IPv6. This often happens when one program sends data to another; the IPv4 equivalent is 127.0.0.1\n"
":: Unspecified - This address may only be used as a source address by an initializing host before it has learned its address; the IPv4 equivalent is 0.0.0.0\n"
"::ffff (i.e., ::ffff:192.0.2.47) These addresses are used to embed IPv4 addresses in an IPv6 address. One use for this is in a dual-stack transition scenario where IPv4 addresses can be mapped into an IPv6 address. See RFC 4038 for more details.\n"
"fc00:: (i.e., fdf8:f53b:82e4::53) Unique Local Addresses (ULAs) - These addresses are reserved for local use in the home and enterprise environments and are not public address spaces; the IPv4 equivalent is 10.0.0.0, 172.16.0.0, 192.168.0.0\n"
"fe80:: (i.e., fe80::200:5aee:feaa:20a2) Link-Local Addresses - These addresses are used on a single link or a non-routed common access network, such as an Ethernet LAN. They do not need to be unique outside of that link; the IPv4 equivalent is 169.254.0.0\n"
"2001:0000:: (i.e., 2001:0000:4136:e378:8000:63bf:3fff:fdd2) Teredo - This is a mapped address allowing IPv6 tunneling through IPv4 NATs. The address is formed using the Teredo prefix, the server’s unique IPv4 address, flags describing the type of NAT, the obfuscated client port, and the client IPv4 address, which is probably a private address. It is possible to reverse the process and identify the IPv4 address of the relay server, which can then be looked up in the relevant RIR’s Whois database.\n"
"2001:0002:: (i.e., 2001:0002:6c::430) Benchmarking - These addresses are reserved for use in documentation. They should not be used as source or destination addresses; the IPv4 equivalent is 198.18.0.0\n\n"
"# https://www.rfc-editor.org/rfc/rfc4291\n"
"2001:DB8:0:0:8:800:200C:417A a unicast address\n"
"FF01:0:0:0:0:0:0:101 a multicast address\n"
"0:0:0:0:0:0:0:1 the loopback address\n"
"0:0:0:0:0:0:0:0 the unspecified address\n"
"2001:DB8::8:800:200C:417A a unicast address\n"
"FF01::101 a multicast address\n"
"::1 the loopback address\n"
":: the unspecified address\n\n"
"# https://www.ibm.com/docs/en/ts4500-tape-library?topic=functionality-ipv4-ipv6-address-formats\n"
"2001:db8:3333:4444:5555:6666:7777:8888\n"
"2001:db8:3333:4444:CCCC:DDDD:EEEE:FFFF\n"
":: (implies all 8 segments are zero)\n"
"2001:db8:: (implies that the last six segments are zero)\n"
"::1234:5678 (implies that the first six segments are zero)\n"
"2001:db8::1234:5678 (implies that the middle four segments are zero)\n"
"2001:0db8:0001:0000:0000:0ab9:C0A8:0102 (This can be compressed to eliminate leading zeros, as follows: 2001:db8:1::ab9:C0A8:102)\n"
"2001:db8:3333:4444:5555:6666:1.2.3.4\n"
"::11.22.33.44 (implies all six IPv6 segments are zero)\n"
"2001:db8::123.123.123.123 (implies that the last four IPv6 segments are zero)\n"
"::1234:5678:91.123.4.56 (implies that the first four IPv6 segments are zero)\n"
"::1234:5678:1.2.3.4 (implies that the first four IPv6 segments are zero)\n"
"2001:db8::1234:5678:5.6.7.8 (implies that the middle two IPv6 segments are zero)\n\n\n"
"# Invalid IPv6\n"
"56FE::2159:5BBC::6594\n"
"2001:db8:a0b:12f0::::0:1\n"
"fe80:2030:31:24\n"
"::8\n"
":::\n"
":1\n"
":\n"
"::2:3:4:5:6:7:8\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.