package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\.?\d+|\d)$`)
var str = `123.321
123..123
1.2.3.4
123.333.123
12389329
1
.123
123.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}