import Foundation
let pattern = #"(?m)((.|\n)*)(\n)^(.*)$\z"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
S
T
A
R
M
A
D
E
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$4\n$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)