// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(obligor_id): (\d+);obligor_id: \d+:").unwrap();
let string = "obligor_id: 505732;obligor_id: 505732:";
let substitution = "$1: $2;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}