import Foundation
let pattern = #"(obligor_id): (\d+);obligor_id: \d+:"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"obligor_id: 505732;obligor_id: 505732:"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1: $2;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)