using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([^\/>]+)>.*?<.*?\/.*?>";
string input = @"Какой то текст <id>Теги и</id> т екст которые нужно удалить</id>. Какой то текст<id>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}