const regex = new RegExp('^(\\d{4}[A-Z]{2}) ([\\w\\.\\\\'\\/\\- ]+) (\\w?[0-9]+[a-zA-Z0-9\\- ]*)', 'igm')
const str = `# Simple
5913ST PRINSENSTRAAT 6
3421ED OUDE SINGEL 11-21
6546EX HORSTACKER 16-44 A
5473CA PLEIN 1969 13A
6533VD ST. JACOBSLAAN 339
7622CN 'T DIJKHUIS 36
5022EH PATER V/D ELSENPLEIN 86
6533VD P/A ST. JACOBSLAAN 339
3262JP WEST-VOORSTRAAT 20
6212BP GLACISWEG 30 K-L
6216BX BECANUSSTRAAT 15A04
9663PR ALBATROSSTRAAT B75
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}