re = /[[:punct:]]*span[[:punct:]]*/
str = 'somethingspan. ..span? spanthank great to hear yourspan'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result