$re = '/{(.*?)}/';
$str = '{0}{5}
{1}{dfdf}
{}
{}{}
{2}{пара, пара п.а пара&па®}
{3}{dfdf!}
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;