const regex = /GLOBAL_DATA\(([^)]*)\)(.*?)\};/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('GLOBAL_DATA\\(([^)]*)\\)(.*?)\\};', 'gs')
const str = `//
// GameSettingData.h
// LowpolyJigsaw
//
// Created by Loc Nguyen on 8/4/17.
//
//
#ifndef GameSettingData_h
#define GameSettingData_h
#include "GameCore/GameData/DataMacro.h"
enum class GameSpeed
{
Slow,
Normal,
Fast
};
struct Address
{
DATA(std::string, streetName, "");
DATA(std::string, houseNumber, "");
DATA(std::string, address, "");
};
struct GLOBAL_DATA(GameSettingData)
{
GameSettingData()
{
address = new Address();
address->streetName = "No Trang Long";
address->houseNumber = "13";
}
DATA(bool, isSoundEnable, true);
DATA(bool, isMusicEnable, true);
DATA(GameSpeed, gameSpeed, GameSpeed::Slow);
DATA(Address*, address, "");
};
struct GLOBAL_DATA(GameSettingData)
{
GameSettingData()
{
address = new Address();
address->streetName = "No Trang Long";
address->houseNumber = "13";
}
DATA(bool, isSoundEnable, true);
DATA(bool, isMusicEnable, true);
DATA(GameSpeed, gameSpeed, GameSpeed::Slow);
DATA(Address*, address, "");
};
#endif /* GameSettingData_h */
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}