const regex = /\Dshared\Dprograms\D6\Dlessons\D\d{2,6}\Dslide_shows$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\Dshared\\Dprograms\\D6\\Dlessons\\D\\d{2,6}\\Dslide_shows$', 'g')
const str = `/shared/programs/6/lessons/1126/slide_shows
/shared/programs/6/lessons/1130/slide_shows
/shared/programs/6/lessons/965/slide_shows
/shared/programs/6/lessons/963/slide_shows
/shared/programs/6/lessons/965/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/1126/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/964/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/944/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/963/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/970/slide_shows
\\Dshared\\Dprograms\\D6\\Dlessons\\D11\\d{2}\\Dslide_shows\$
\\Dshared\\Dsections\\D\\d{3,5}\\D.{1,10}[=]{0,1}[program_id]*\\D{0,1}109`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}