import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)|target)(?:(?!luke|(?:end)?target).)*\\Kluke(?=(?:(?!(?:end)?target).)*endtarget)";
final String string = "targethelloluketestlukeluketestluktestingendtarget\n"
+ "sourcehelloluketestlukeluketestluktestingendsource";
final String subst = "<SOME>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}