use strict;
my $str = 'targethelloluketestlukeluketestluktestingendtarget
sourcehelloluketestlukeluketestluktestingendsource';
my $regex = qr/(?:\G(?!\A)|target)(?:(?!luke|(?:end)?target).)*\Kluke(?=(?:(?!(?:end)?target).)*endtarget)/mp;
my $subst = '<SOME>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";