using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?<!')(.*?)(?<!\\)(?<!')""";
string input = @"$str = ""this is something"";
$str = ""this is {$another}"";
$str = ""could be {$hello['world']}"";
$str = ""and $hello[world] another"";
$str = ""building <div style=\""width: 100%\"" data-var=\""{$var}\""></div>"";
$str = '<elem prop=""' . $var . '"">';
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}