re = /"(?<!')(.*?)(?<!\\)(?<!')"/m
str = '$str = "this is something";
$str = "this is {$another}";
$str = "could be {$hello[\'world\']}";
$str = "and $hello[world] another";
$str = "building <div style=\\"width: 100%\\" data-var=\\"{$var}\\"></div>";
$str = \'<elem prop="\' . $var . \'">\';
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end