import re
regex = re.compile(r"\s{1,}\S{1,}$", flags=re.MULTILINE)
test_str = ("ITGIS.COMP_OP_STN cos\n"
"ITGIS.NS_DIVISIONS nsd\n"
"ITGIS.COMP_OP_STN cos\n"
"ITGIS.NSPD_RESP_ZONE nrz\n"
"ITGIS.COMP_OP_STN cos\n"
"PUBDATA.US_COUNTIES usc\n"
"ITGIS.COMP_OP_STN cos\n"
"PUBDATA.US_CITIES_BOUNDARIES uscb\n"
"ITGIS.COMP_OP_STN cos\n"
"nsdMatches nsd\n"
"nrzMatches nrz\n"
"cityBoundaryMatches\n"
"countyMatches\n"
"ITGIS.NSPD_LOCATIONS nl\n"
"ITGIS.NS_DIVISIONS nd\n"
"NFSAPP.CONTROL nfsac\n"
"PUBDATA.US_CITIES c\n"
"ENGXING.CI_LOCATIONANDCLASSIFICATION cils\n"
"ITGIS.NS_DIVISIONS nsd\n"
"ENGXING.CI_LOCATIONANDCLASSIFICATION cils\n"
"ITGIS.NSPD_RESP_ZONE nrz\n"
"ENGXING.CI_LOCATIONANDCLASSIFICATION cils\n"
"PUBDATA.US_COUNTIES usc\n"
"ENGXING.CI_LOCATIONANDCLASSIFICATION cils\n"
"PUBDATA.US_CITIES_BOUNDARIES uscb\n"
"ENGXING.DOTLIST dl\n"
"INNER JOIN ENGXING.CI_LOCATIONANDCLASSIFICATION cils\n"
"ENGXING.INVENTORY_QUE q\n"
"nsdMatches nsd\n"
"ENGXING.CI_OPERATINGRAILROAD cior\n"
"nrzMatches nrz\n"
"cityBoundaryMatches\n"
"countyMatches\n"
"ITGIS.NSPD_LOCATIONS nl\n"
"ITGIS.NS_DIVISIONS nd\n"
"ENG.ENG_CROSSING ec\n"
"NFSAPP.CONTROL nfsac\n"
"PUBDATA.US_CITIES c\n"
"EGIS.ENG_MPMARK mp\n"
"ITGIS.NS_DIVISIONS nsd\n"
"EGIS.ENG_MPMARK mp\n"
"ITGIS.NSPD_RESP_ZONE nrz\n"
"EGIS.ENG_MPMARK mp\n"
"PUBDATA.US_COUNTIES usc\n"
"EGIS.ENG_MPMARK mp\n"
"PUBDATA.US_CITIES_BOUNDARIES uscb\n"
"EGIS.ENG_MPMARK mp\n"
"nrzMatches nrz\n"
"nsdMatches nsd\n"
"cityBoundaryMatches\n"
"countyMatches\n"
"ITGIS.NSPD_LOCATIONS nl\n"
"ITGIS.NS_DIVISIONS nd\n"
"NFSAPP.CONTROL nfsac\n"
"PUBDATA.US_CITIES c\n"
"EGIS.ENG_SWITCH s\n"
"ITGIS.NS_DIVISIONS nsd\n"
"EGIS.ENG_SWITCH s\n"
"ITGIS.NSPD_RESP_ZONE nrz\n"
"EGIS.ENG_SWITCH s\n"
"PUBDATA.US_COUNTIES usc\n"
"EGIS.ENG_SWITCH s\n"
"PUBDATA.US_CITIES_BOUNDARIES uscb\n"
"EGIS.ENG_SWITCH s\n"
"nsdMatches nsd\n"
"nrzMatches nrz\n"
"cityBoundaryMatches\n"
"countyMatches\n"
"ITGIS.NSPD_LOCATIONS nl\n"
"ITGIS.NS_DIVISIONS nd\n"
"NFSAPP.CONTROL nfsac\n"
"PUBDATA.US_CITIES c\n"
"EGIS.ENG_TOWER t\n"
"ITGIS.NS_DIVISIONS nsd\n"
"EGIS.ENG_TOWER t\n"
"ITGIS.NSPD_RESP_ZONE nrz\n"
"EGIS.ENG_TOWER t\n"
"PUBDATA.US_COUNTIES usc\n"
"EGIS.ENG_TOWER t\n"
"PUBDATA.US_CITIES_BOUNDARIES uscb\n"
"EGIS.ENG_TOWER t\n"
"nsdMatches nsd\n"
"nrzMatches nrz\n"
"cityBoundaryMatches\n"
"countyMatches\n"
"ITGIS.NSPD_LOCATIONS nl\n"
"ITGIS.NS_DIVISIONS nd\n"
"PUBDATA.US_CITIES c\n"
"ITGIS.COMP_AEI_SCNR s\n"
"ITGIS.NS_DIVISIONS nsd\n"
"ITGIS.COMP_AEI_SCNR s\n"
"ITGIS.NSPD_RESP_ZONE nrz\n"
"ITGIS.COMP_AEI_SCNR s\n"
"PUBDATA.US_COUNTIES usc\n"
"ITGIS.COMP_AEI_SCNR s\n"
"PUBDATA.US_CITIES_BOUNDARIES uscb\n"
"ITGIS.COMP_AEI_SCNR s\n"
"nsdMatches nsd\n"
"nrzMatches nrz\n"
"cityBoundaryMatches\n"
"countyMatches\n"
"ITGIS.NSPD_LOCATIONS nl\n"
"ITGIS.NS_DIVISIONS nd\n"
"NFSAPP.CONTROL nfsac\n"
"PUBDATA.US_CITIES c\n"
"ITGIS.NSPD_LOCATIONS l\n"
"ITGIS.NS_DIVISIONS nsd\n"
"ITGIS.NSPD_LOCATIONS l\n"
"ITGIS.NSPD_RESP_ZONE nrz\n"
"ITGIS.NSPD_LOCATIONS l\n"
"PUBDATA.US_COUNTIES usc\n"
"ITGIS.NSPD_LOCATIONS l\n"
"PUBDATA.US_CITIES_BOUNDARIES uscb\n"
"ITGIS.NSPD_LOCATIONS l\n"
"nsdMatches nsd\n"
"nrzMatches nrz\n"
"cityBoundaryMatches\n"
"countyMatches\n"
"ITGIS.NSPD_LOCATIONS nl\n"
"PUBDATA.US_CITIES c\n"
"NSPD.NSPD_POI poi\n"
"ITGIS.NS_DIVISIONS nsd\n"
"NSPD.NSPD_POI poi\n"
"ITGIS.NSPD_RESP_ZONE nrz\n"
"NSPD.NSPD_POI poi\n"
"PUBDATA.US_COUNTIES usc\n"
"NSPD.NSPD_POI poi\n"
"PUBDATA.US_CITIES_BOUNDARIES uscb\n"
"NSPD.NSPD_POI poi\n"
"nsdMatches nsd\n"
"nrzMatches nrz\n"
"cityBoundaryMatches\n"
"countyMatches\n"
"ITGIS.NSPD_LOCATIONS nl\n"
"PUBDATA.US_CITIES c\n"
"ITGIS.ITGIS_MP100S mp\n"
"ITGIS.NS_DIVISIONS nsd\n"
"ITGIS.ITGIS_MP100S mp\n"
"ITGIS.NSPD_RESP_ZONE nrz\n"
"ITGIS.ITGIS_MP100S mp\n"
"PUBDATA.US_COUNTIES usc\n"
"ITGIS.ITGIS_MP100S mp\n"
"PUBDATA.US_CITIES_BOUNDARIES uscb\n"
"ITGIS.ITGIS_MP100S mp\n"
"NFSAPP.CONTROL nfsac\n"
"nrzMatches nrz\n"
"nsdMatches nsd\n"
"cityBoundaryMatches\n"
"countyMatches\n"
"ITGIS.NSPD_LOCATIONS nl\n"
"ITGIS.NS_DIVISIONS nd\n"
"PUBDATA.US_CITIES c\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")