# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:(?!end).)*start.*/*/gm;t' <<< "line_end; start
line start; end
"