# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<!--([^<|\s|\[|>|go{2}gleo]).*?-->//gm;t' <<< "something here<!---->
<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
something here<!-- -->
<!--[if lt IE 9]> <!-- -->
Here is some code.
<![endif]-->
<!--[if !IE]> -->
<![endif]-->"