re = /^(?!.*chocolate).*$/m
str = 'I like chocolate
bananas choco
chocolate cake'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end