$re = '/^(?!.*\bchocolate\b).*$/m';
$str = 'I like chocolate
bananas choco
chocolate cake
blackchocolate
chocolatechips';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);