import re
regex = re.compile(r"(?i)(?<Lp>\d{1,2}(?![\s\S]*?(Lp\.|Ilość|jm\.)))\s*(?<NazwaProduktu1>([\S ]*?[\n\r]*){1,3})[\s\a]*(?<Ilosc>\d*)[.]?\s*(?<jm>[a-z]{3})[.]?[\s\a]*[\d\,\% \.]*(?<NazwaProduktu2>([a-ż\d ]*[\n\r]*){1,3})[\s\a]*", flags=re.MULTILINE | re.UNICODE)
test_str = ("AKTURA FV000821 :JAAC*fibf:\n"
"DATA WYSTAWIENIA : 2020.06.08 ZLECENIE: 01\n"
"MIEJSCE WYSTAWIENIA : TORUŃ\n"
"DATA DOSTAWY TOWARU : 2020.06.08 UWAGI : zam. T561552 Z1\n"
"SPRZEDAWCA: \"MEGA-TOOLS\" S.C.\n"
" Marek Śpiewak,Mirosław Śpiewak ul.Osikowa 34 87-100 Toruń NIP 9562093313\n"
" ING Bank Śląski S.A. O/Toruń\n"
" 49 1050 1979 1000 0022 7285 0849\n"
" NABYWCA: Pojazdy Szynowe PESA Bydgoszcz Spółka Akcyjna ul.Zygmunta Augusta 11 85-082 Bydgoszcz\n"
" NIP 554-031-17-75\n"
" [07-668]\n"
" Lp Opis towaru/uslugi Ilość jm. Cena Wartosc VAT\n"
"-----------------------------------------------------------------------------------------------\n"
" 1 INNE-ELEK-9512 11. szt. 66,00 726,00 23.0% Lampa warsztatowa 30LED z ładowarką\n"
"---------------------------------------------------------------------------------------------- 726,00\n"
"Rozliczenie VAT Netto Podatek Brutto ----------------------------------------------------wg stawki 23.0% : 726,00 166,98 892,98 -----------------------------------------------------\n"
"RAZEM : 726,00 166,98 892,98\n"
"DO ZAPŁATY: 892,98 PLN\n"
"SŁOWNIE : osiemset dziewiecdziesiat dwa zl dziewiecdziesiat osiem gr\n"
"ZAPLACONO GOTOWKA : 0,00 PLN\n"
"POZOSTAŁO DO ZAPŁATY : 892,98 PLN\n"
"PŁATNE : PRZELEW DO 2020.08.07\n"
"NA KONTO : 49 1050 1979 1000 0022 7285 0849\n"
"Za niezapłacone należności w terminie, będą naliczone odsetki w wysokości ustawowej.\n"
"Dokument wystawiony i dostarczony nabywcy w formie elektronicznej.\n"
"Wystawca dokumentu FV000821 : MIROSŁAW ŚPIEWAK\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")