re = /Data Name='RuleName'>technique_id=(?<technique_id>[^,]+),technique_name=(?<technique_name>[^<]+)</m
str = '<Data Name=\'RuleName\'>technique_id=T1055.001,technique_name=Dynamic-link Library</Data>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end