#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=signature date\.\r?\n)\w+(?=\sSignatory attests)"
Local $sString = "to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date." & @CRLF & _
"Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the" & @CRLF & _
"Form 4506-C. See instructions." & @CRLF & _
"" & @CRLF & _
"to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date." & @CRLF & _
"X Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the" & @CRLF & _
"Form 4506-C. See instructions." & @CRLF & _
"" & @CRLF & _
"to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date." & @CRLF & _
"asdas Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the" & @CRLF & _
"Form 4506-C. See instructions." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")