# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=signature date\.\r?\n)\w+(?=\sSignatory attests)"
test_str = ("to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.\n"
"Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the\n"
"Form 4506-C. See instructions.\n\n"
"to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.\n"
"X Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the\n"
"Form 4506-C. See instructions.\n\n"
"to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.\n"
"asdas Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the\n"
"Form 4506-C. See instructions.\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.